Soporte Themes y Mods SMF Tricks

0 Members and 1 Guest are viewing this topic.

*
omolinete
Sniffer
Hola!

Este es mi primer mensaje, así que al César lo que es del César: Enhorabuena por vuestro gran trabajo!!

Dicho esto, abro este hilo porque estoy montando un foro basado en el theme Redsy.

Tengo todo configurado para que automáticamente según se visite la URL, redirija al modo HTTPS, y aparentemente lo hace bien.

Sin embargo, debe de haber algo que se me escapa por algún lado y que hace que por ejemplo la tipografía no la herede bien en modo HTTPS pero sí en HTTP. Es decir, si visitas el foro via HTTP, cargan las fuentes bien, pero si lo haces en modo HTTPS es como si no se cargaran, haciendo que cargue una tipografía de estilo más clásico.

¿Qué se me puede estar escapando? Dentro de la base de datos en MySQL, todas las URLs del motor del foro tienen especificado "https" y sin embargo para el tema de la tipografía es como si no lo heredara ese cambio.

A lo mejor está "hardcodeado" la cadena "http" en algún source, pero a saber cual.

¿Alguien podría echarme una mano, por favor?

Mil gracias anticipadas y saludos!






*
Daniel
#1
Webmaster
Bootstrap.css (Themes/Redsy/css)
Buscar:
Code: [Select]
@import url(http://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800);
Reemplazar por:
Code: [Select]
@import url(https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800);
*
omolinete
#2
Sniffer
Hola Daniel,

Hice el cambio que me dijiste, y funcionó! GENIAL, muchas gracias!!

Ahora sólo tengo una duda más y también es concerniente al tema de la tipografía en el theme Redsy, y es la siguiente:

En la image que adjunto con este post, señalo en recuados de color rojo que hay menús y submenús que aparecen utilizando otro tipo de fuente que no es la utilizada globalmente en todo el theme.

Mi pregunta es: ¿Esto es así a propósito y por defecto, o es que no está heredando bien el cambio como ocurría con mi post anterior y hay que cambiar la cadena a "https" en algún otro source?

Si la tipografía que viene por defecto para este caso es la correcta, ¿cómo o dónde debo cambiarla para que sea la misma que se utiliza globalmente en el resto del Theme, y como se llama la tipografía que se utiliza en el resto del theme y que es más sencilla, clara y estética?

Muchas gracias de nuevo por adelantado!!

Saludos

-----------

Hola de nuevo,

Edito el post para añadir que he investigado un poco y no se trata de ningún problema de desconfiguración, sino que esos menús y submenús se basan en la tipografía "Segoe UI", la cual está licencia por Microsoft y no se puede utilizar en servidores Linux, por lo tanto SMF ni sus themes la distribuyen.

Sugiero que quien esté en el mismo caso que yo, edite el archivo ".../Themes/Redsy/css/index.css" y sustituya este bloque:

Code: [Select]
.dropmenu a span
{
        display: block;
        padding: 0;
        font-size: 9pt;
    font-weight: 600;
        font-family: "Segoe UI";
        transition: color .35s ease-in-out;
   -moz-transition: color .35s ease-in-out;
   -webkit-transition: color .35s ease-in-out;
}

Por el siguiente:

Code: [Select]
.dropmenu a span
{
        display: block;
        padding: 0;
        font-size: 10pt;
    font-weight: 600;
        font-family: "Open Sans";
        transition: color .35s ease-in-out;
   -moz-transition: color .35s ease-in-out;
   -webkit-transition: color .35s ease-in-out;
}
« Last Edit: December 20, 2015, 05:29:39 AM by omolinete »
*
Diego Andrés
#3
Webmaster
Edito el post para añadir que he investigado un poco y no se trata de ningún problema de desconfiguración, sino que esos menús y submenús se basan en la tipografía "Segoe UI", la cual está licencia por Microsoft y no se puede utilizar en servidores Linux,

Buen dato, gracias por la información.