Soporte Themes y Mods SMF Tricks

0 Members and 1 Guest are viewing this topic.

*
WINTX
ST Fan
Error al instalar el mod Popular Topics
August 21, 2015, 06:56:44 PM
Encima del foro me sale lo siguiente al instalar el mod

Code: [Select]
$txt['PopularTopics_enable'] = 'Enable Popular Topics mod'; $txt['PopularTopics_enable_desc'] = 'This will enable/disable the mod.'; $txt['percent'] = 'percent'; $txt['PopularTopics_views_percent'] = 'Views popularity percent'; $txt['PopularTopics_views_percent_desc'] = 'By default is 70%'; $txt['PopularTopics_replies_percent'] = 'Replies popularity percent'; $txt['PopularTopics_replies_percent_desc'] = 'By default is 30%';


El theme es Wrap
La version de SMF es 2.0.10
La url del sitio web: wintxcoders.com/forum  (En estos momentos no sale el error debido a que tengo el mod desinstalado)

Les adjunto el display.template.php y el index.template.php para que así le puedan echar un ojo si pueden  :D

Muchas gracias.






*
Diego Andrés
#1
Webmaster
Re: Error al instalar el mod Popular Topics
August 21, 2015, 08:32:31 PM
No es error de ninguno de los dos archivos, simplemente ve al archivo Modifications.idioma.php y asegúrate de que la etiqueta de cierre de php este al final de todo, o en su defecto elimínala.
*
WINTX
#2
ST Fan
Re: Error al instalar el mod Popular Topics
August 22, 2015, 04:43:15 PM
Hola, el idioma que uso es spanish_es-utf8

Y solamente tengo esto puesto..

Code: [Select]
<?php
// Version: 2.0; Modifications


?>

Muchas gracias por tu ayuda y soporte
*
Diego Andrés
#3
Webmaster
Re: Error al instalar el mod Popular Topics
August 22, 2015, 05:51:05 PM
Revisa en los demás archivos Modifications puede ser que el error proviene de otro.
*
WINTX
#4
ST Fan
Re: Error al instalar el mod Popular Topics
August 22, 2015, 06:05:06 PM
Puede ser pro que no tengo instalado el spanish_latín?
*
Diego Andrés
#5
Webmaster
Re: Error al instalar el mod Popular Topics
August 22, 2015, 06:21:05 PM
No, eso no tiene nada que ver.
Lo mejor será que revises el parse del mod y que las 4 modificaciones que hace se hayan realizado correctamente.
*
WINTX
#6
ST Fan
Re: Error al instalar el mod Popular Topics
August 23, 2015, 10:50:44 AM
Hola este archivo:

Code: [Select]
ManagePosts.php
Me dice que no lo tengo ni en el theme default ni en el theme que uso por defecto WRAP
*
Diego Andrés
#7
Webmaster
Re: Error al instalar el mod Popular Topics
August 24, 2015, 07:43:57 AM
Es porque ese archivo no es un template, es un archivo que se encuentra en Sources
*
WINTX
#8
ST Fan
Re: Error al instalar el mod Popular Topics
August 24, 2015, 08:51:54 AM
En las operaciones dice que haga lo siguiente:

Busco:
Code: [Select]
array('check', 'enablePreviousNext'),
Reemplazo por:
Code: [Select]
array('check', 'enablePreviousNext'),
                '',
                        // Popular Topics
                        array('check', 'PopularTopics_enable', 'subtext' => $txt&#91;'PopularTopics_enable_desc'&#93;),
                        array('float', 'PopularTopics_views_percent', 'postinput' => $txt&#91;'percent'&#93;, 'subtext' => $txt&#91;'PopularTopics_views_percent_desc'&#93;),
                        array('float', 'PopularTopics_replies_percent', 'postinput' => $txt&#91;'percent'&#93;, 'subtext' => $txt&#91;'PopularTopics_replies_percent_desc'&#93;),

Pero el hace lo siguiente si se instala automáticamente:
Code: [Select]
array('check', 'enablePreviousNext'),
'',
// Popular Topics
array('check', 'PopularTopics_enable', 'subtext' => $txt['PopularTopics_enable_desc']),
array('float', 'PopularTopics_views_percent', 'postinput' => $txt['percent'], 'subtext' => $txt['PopularTopics_views_percent_desc']),
array('float', 'PopularTopics_replies_percent', 'postinput' => $txt['percent'], 'subtext' => $txt['PopularTopics_replies_percent_desc']),
*
Diego Andrés
#9
Webmaster
Re: Error al instalar el mod Popular Topics
August 24, 2015, 08:54:42 AM
No se en donde viste el parse porque la operación debe ser como lo tienes en el segundo código.

Lo que puedes hacer es ir al log de errores y revisar de donde proviene el problema.
*
WINTX
#10
ST Fan
Re: Error al instalar el mod Popular Topics
August 24, 2015, 09:09:39 AM
URLhttp://wintxcoders.com/forum/index.php?
mensaje8: Undefined index: sh_remove_items
Archivo: /usr/share/nginx/www/wintxcoders.com/forum/Themes/default/languages/TeamPage.spanish_es-utf8.php (body_above sub template - eval?)
Línea: 397
*
Diego Andrés
#11
Webmaster
Re: Error al instalar el mod Popular Topics
August 24, 2015, 03:36:46 PM
Ese error no tiene nada que ver con el mod, es mas eso ni viene en el theme wrap.