Support for SMF Tricks Themes & Mods

0 Members and 1 Guest are viewing this topic.

*
justjim
Sniffer
Red Sample Request
February 10, 2015, 09:23:27 AM

Do you have any plans to add the Goggle+ button in the footer options?

Or is there an easy way to do so?






*
Diego Andrés
#1
Webmaster
Re: Red Sample Request
February 10, 2015, 10:13:38 AM
No, but we can help you to do it, just leave the icon
*
justjim
#2
Sniffer
Re: Red Sample Request
February 11, 2015, 07:28:22 AM
Thank you. I have attached the image resized to 32px X 32px matching the size of the other social buttons.
*
Diego Andrés
#3
Webmaster
Re: Red Sample Request
February 13, 2015, 08:06:11 PM
Sorry, my fault. It has no sense to attach the image lol.
Just add it to /Themes/RedSample/images/theme/google.png

And then make this changes.


css/index.css
add at the end of the file
Code: [Select]
#quicknav a.google {
background: url(../images/theme/google.png) no-repeat !important;
background-position: 0 0 !important;
}

index.template.php find
Code: [Select]
if(!empty($settings['twitter_username']))
echo '
<li><a class="social_icon twitter" href="http://twitter.com/', $settings['twitter_username'] , '" target="_blank"></a></li>';

Replace with
Code: [Select]
echo '
<li><a class="social_icon google" href="http://" target="_blank"></a></li>';

if(!empty($settings['twitter_username']))
echo '
<li><a class="social_icon twitter" href="http://twitter.com/', $settings['twitter_username'] , '" target="_blank"></a></li>';

And just put your google url here:  href="http://"

Regards
*
justjim
#4
Sniffer
Re: Red Sample Request
February 18, 2015, 04:36:19 PM
Hi Diego

Thank you for help, it worked beautifully.


Here is a link to my site:


http://vendorrender.com/

Jim
« Last Edit: February 18, 2015, 04:40:09 PM by justjim »
*
Diego Andrés
#5
Webmaster
Re: Red Sample Request
February 18, 2015, 04:49:28 PM
That's because you didn't put your url there.

href="{url/link}"
*
justjim
#6
Sniffer
Re: Red Sample Request
February 19, 2015, 07:24:57 AM
Hi Diego

You replied before I edited my last reply - I found the problem and corrected it - it was because I had too many " in the code line. But its fixed.

Thanks
*
Diego Andrés
#7
Webmaster
Re: Red Sample Request
February 21, 2015, 12:53:11 PM
Great, I'll mark this as solved, and move it to the support boards