Show Posts - upgraders

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - upgraders

Pages:
1
I still have had no luck fixing this error.  Any other ideas or suggestions?

2
Thanks again for your help, but no the same errors occur with the change in code.

3
Here you go, thanks.

4
I probably should have turned off the Template Eval.  The error occurs in the Index.template.php  specifically in the Template_menu function

Code: [Select]
function template_menu()
{
global $context, $settings, $options, $scripturl, $txt;

foreach ($context['menu_buttons'] as $act => $button)
{
echo '
<li id="button_', $act, '" class="', $button['sub_buttons'] ? 'dropdown ' : '', '', $button['active_button'] ? 'active ' : '', '">
<a ', $button['sub_buttons'] ? 'class="dropdown-toggle" ' : '', 'href="', $button['sub_buttons'] ? '#' : $button['href'], '"', isset($button['target']) ? ' target="' . $button['target'] . '"' : '', '', $button['sub_buttons'] ? ' data-toggle="dropdown"' : '', '>
', $button['title'], '
', $button['sub_buttons'] ? '<span class="caret"></span>' : '' ,'
</a>';
if (!empty($button['sub_buttons']))
{
echo '
<ul class="dropdown-menu" role="menu">';

foreach ($button['sub_buttons'] as $childbutton)
{
echo '
<li>
<a href="', $childbutton['href'], '"', isset($childbutton['target']) ? ' target="' . $childbutton['target'] . '"' : '', '>
', $childbutton['title'] , '
</a>
</li>';
}
echo '
</ul>';
}
echo '
</li>';
}
}

Thanks again for any help!



Lines #506,507 & 509

Code: [Select]
<li id="button_', $act, '" class="', $button['sub_buttons'] ? 'dropdown ' : '', '', $button['active_button'] ? 'active ' : '', '">
<a ', $button['sub_buttons'] ? 'class="dropdown-toggle" ' : '', 'href="', $button['sub_buttons'] ? '#' : $button['href'], '"', isset($button['target']) ? ' target="' . $button['target'] . '"' : '', '', $button['sub_buttons'] ? ' data-toggle="dropdown"' : '', '>
', $button['title'], '
', $button['sub_buttons'] ? '<span class="caret"></span>' : '' ,'


5
I hope not to bother you again, but I am having another problem, actually it looks as though it's been going on for a while since I first installed the Theme.  You addressed it in this post, http://smftricks.com/index.php?topic=712.0   sort of.  I am using SMFhack Menu Pro, although I am not 100% sure this is the reason.  I have no found any commonality, except that a few reference this error with the reseller theme. So I hope to reach out one last time to fix this.

If you read post #83 it also references the problem:
https://translate.google.com/translate?hl=en&sl=ru&u=http://www.simplemachines.ru/index.php%3Ftopic%3D17952.50&prev=search

 I have included what I think you might want to look at.  Subs, intext.template and the profile.english.



The errors I get are in the 1000's and they are all similar in some way and almost on every page of the forum:

Apply Filter: Only show the error messages of this URLhttp://www.vapeshopforum.com/index.php?board=10.0;sort=repliesApply Filter: Only show the errors with the same message8: Undefined index: sub_buttonsApply Filter: Only show the errors from this file File: <snip> .COM/www/Themes/default/languages/Profile.english.php (body_above sub template - eval?)
Line: 506

Apply Filter: Only show the error messages of this URLhttp://www.vapeshopforum.com/index.php?action=admin;area=logs;sa=errorlog;descApply Filter: Only show the errors with the same message8: Undefined index: sub_buttonsApply Filter: Only show the errors from this file File: D<snip> VAPESHOPFORUM.COM/www/Themes/default/languages/Profile.english.php (body_above sub template - eval?)


http://www.vapeshopforum.com/index.php?topic=2.0Apply Filter: Only show the errors with the same message8: Undefined index: sub_buttonsApply Filter: Only show the errors from this file File: D:/webspace/VAPESHOPFORUM.COM/www/Themes/default/languages/Profile.english.php (body_above sub template - eval?)
Line: 507



6
Thanks,  I must have missed that!  thanks again for your help!! 

7
thanks,  I haven't been able to find it, which is why I posted it again here.  It was asked in a long thread but never addressed.

8
You are awesome!  I think that fixes that issue!  Can you share what you changed?

Is there any adjustment that can be made to the Avatar on a mobile or smaller browser window.  When you shrink the window, right at the point where the content shifts, the Avatar gets very large and pixilated, until you shrink down more.  IT would be nice to be able to create a "Max-Size" that could be adjusted but keep the responsiveness.

9
Thanks.. SO much!  it is a lot better, but it seems to be taking up a little too much room. Ideally the forum expands to the browser size and there will be left and right areas for ads using the SMFhacks Ad seller mod.  can you take a look to see if we can get it a little bit more proportionate?  http://www.vapeshopforum.com/

10
Thanks I look forward to it!

11
Thanks for your help. I have attached both files as you requested.

Jason

12
Hello Daniel,  You have an amazing beautiful theme and thank you for your efforts.  I have spent most of the day reading from your replies in two different forums just to make sure my problem was not already discovered.  I saw a couple of people mention it but I think they got lost in the thread as they were never replied to. 

The problem that I have is two fold but it is in regards to the responsive image resizing.  The reseller.css has the max-width: 100% for the img tags and they  work great, except in two areas on your theme.  I, like many others are using the Ad Seller Pro from SMFhacks that uses the tables on either side of the theme pages. When using Chrome the images remain very small.  using chrome if you go to here http://www.vapeshopforum.com/index.php  and look to the right banor.  Now if you open the same page in IE the problem is gone the image is perfect, however if you try to resize the Chrome remains small but IE is not responsive. 

Now if you resize and look at a post, http://www.vapeshopforum.com/index.php?topic=5.0  the avatar gets much bigger (so in mobile this takes up a lot of room, rather than get smaller. 

I have tried editing the DIV tags and SMFHacks is also trying to figure out a solution. You are a brilliant person, so my hope lie in a solution from you.  I hope you can find the time to help as I am running out of time to get this done. 

I found several articles on the same problem.  I tried to do this http://jsfiddle.net/TAE3w/21/ and borrowed the same code since ti seems to work in the table. But eh table I think at least the TD is the problem.  If you inspect the elements on my page you can see it is exactly the same, yet the banner on the top right is super small and the SAME one on the bottom is very large.

Thanks for everything you do for SMF

Jason


Pages: